Kalkulator wyborczy

Kalkulator wyborczy czyli plik Excela przeliczający głosy na mandaty. Uwzględnia przekroczenie progu wyborczego (5% dla partii i 8% dla koalicji). Oczywiście jest oparty o metodę D’Hondta. W roku podwójnych wyborów może się przydać.

Plik Excela do pobrania jest tu:

Kalkulator wyniku wyborów

Plik Excela jest bez makr. A jak działa?

Do wypełnienia są żółte pola. W komórce D6 wpisujemy liczbę mandatów do podziału, w komórkach C4:M4 – oznaczenie T/N dla koalicji, a w komórkach C5:M5 – liczbę głosów uzyskanych przez poszczególne partie. I już całą reszta jest obliczana automatycznie.

Komórka B10 to suma wszystkich głosów czyli suma zakresu C5:M5.
W wierszu 6 mamy formułę np. w C6: =C5/$B$10 – w pozostałych kolumnach wiersza 6 – analogicznie. W ten sposób obliczamy procent uzyskanych głosów dla poszczególnych partii.
W komórce C7 (i analogicznie w kolumnach od D do M) jest formuła:
=JEŻELI(C4=”T”;JEŻELI(C6>=8%;”T”;”N”);JEŻELI(C6>=5%;”T”;”N”))
– następuje tu sprawdzenie, w zależności od tego czy jest to koalicja czy nie, czy został przekroczony próg wyborczy.

Metoda H’ondta polega na tym, że w pierwszym kroku wstawiamy do tabeli wszystkie wyniki, w kolejnym wierszu – dzielimy te wartości przez 2, w następnym – przez 3 itd.
Wyniki tych obliczeń są umieszczone od wiersza 14 w dół.

Formuły zawarte w wierszu 14 – to:
np. komórka C14: =JEŻELI(LUB(C5=””;C7=”N”);0;C5) – czyli jeżeli w tabeli z danymi w kolumnie nie ma wartości lub wynik działania formuły w wierszu 7 jest “N”  – jest ona pobierana do wiersza 14, jeżeli nie – ZERO.

Od wiersza 15 – formuła wygląda tak:
np. w komórce C15: =JEŻELI(LUB(C14=””;C14jeżeli w komórce  powyżej jest wartość co najmniej 1 – jest ona dzielona przez wartość w komórce B15 czyli 2. Analogicznie – w kolejnych wierszach.

Formuła B13 jest natomiast formuła:

=MAX.K(C14:M313;D1)

Wyznacza ona k-tą wartość maksymalną z zakresu obliczeń. Wartość k jest wyznaczona przez liczbę mandatów do podziału – zapisana jest w komórce D1. Wartości większe i równe tej wartości minimalnej są oznaczone w obliczeniach na jasnoniebiesko. Tu wykorzystałam formatowanie warunkowe:

W wierszu 8 jest wyznaczona liczba mandatów dla danej partii. Zastosowałam tu formułę:
=JEŻELI(C7=”T”;LICZ.JEŻELI(C14:C313;”>=” &$B13);0)

Następuje tu sprawdzenie – ile w zakresie obliczeń dla danej kolumny występuje liczb niemniejszych od B7.

I już, wszystko jasne. – można wspomóc PKW kalkulatorem wyborczym.

8 myśli na temat “Kalkulator wyborczy”

  1. Nie działa. Po zmianie liczby mandatów na 460, w komórce B13 tj. podającej minimalna liczbę głosów pojawia się błąd #LICZBA!

    1. Faktycznie, robiłam go pod inne wybory, gdzie jest mniej mandatów. Wystarczy przeciągnąć w dół formuły w dolnej części arkusza.
      Oczywiście już poprawiłam plik – teraz można liczyć też przy 460 mandatach.

    1. To działa trochę inaczej – mandaty są rozdzielane tylko na te komitety, które przekroczyły próg. Nie ma prostego “przeniesienia” głosów, choć faktycznie najbardziej korzysta ten komitet, który zdobył najwięcej głosów.

Dodaj komentarz