Licz.Jeżeli

Licz.Jeżeli to jedna z funkcji statystycznych Excela. W wyniku jej działania otrzymujemy ilość komórek spełniających określone kryterium wyszukiwania.
Argumenty funkcji to:

      • Zakres – zakres komórek, w którym chcemy wyliczyć ilość ilość spełniających dany warunek
      • Kryteria – warunek do spełnienia

Obydwa argumenty są wymagane.

W praktyce  wygląda to tak:

Mamy prostą tabelkę z danymi. Chcąc policzyć ile jest kobiet (czyli oznaczenie “K” w kolumnie B) przy użyciu funkcji Licz.Jeżeli zapisujemy:
=LICZ.JEŻELI(B2:B14;”K”)
Argumentu Kryteria nie musimy wpisywać w cudzysłowie, Excel sam przekształci wpisaną tam wartość w tekst. Wielkość liter nie ma tu znaczenia.
Gdybyśmy chcieli policzyć ilość mężczyzn – jako kryterium wystarczy wstawić literkę M.
Chcąc natomiast policzyć ilość osób, które wpłaciły np.10zł – możemy zastosować formułę:
=LICZ.JEŻELI(D2:D14;10)

Kryterium nie musi być jednak wpisywane na sztywno do funkcji. Można tu odwoływać się do wartości w innej komórce. W załączonym przykładzie niech będzie to np.komórka F1. Formuła odwołująca się do niej to:
=LICZ.JEŻELI(B2:B14;F1)
Jeżeli w komórce F1 wpiszemy np.K – to funkcja zwróci nam ilość kobiet. Wystarczy zmienić na M i policzymy mężczyzn.

Kryterium wyszukiwania może być także bardziej złożone. Jeżeli chcielibyśmy np. sprawdzić, do ilu osób w tabelce przypisana jest np. kwota powyżej 100zł możemy zastosować formułę:
=LICZ.JEŻELI(D2:D14;”>100″)
lub odwołując się do wartości np.w komórce F1:
=LICZ.JEŻELI(D2:D14;”>” & F1)
Warto zauważyć, że adres komórki (czyli F1) musi być poza znakiem cudzysłowu, korzystamy tu z łączenia tekstów za pomocą znaku konkatenacji &.

Można też tworzyć bardziej złożone kryteria. Załóżmy, że w kolumnie A chcemy wyszukać liczbę imion rozpoczynających się na literę A. Formuła w tym przypadku będzie wyglądać tak:
=LICZ.JEŻELI(A2:A14;”A*”)
Znak * oznacza dowolny ciąg tekstowy, o dowolnej długości, również zerowy. W przypadku odwołania do komórki F1 wygląda to tak:
=LICZ.JEŻELI(A2:A14;F1 & “*”)

Symbol ? oznacza dokładnie jeden znak. Czyli funkcja
=LICZ.JEŻELI(A2:A14;”*a?”)
wskaże ilość komórek w kolumnie A, zawierających literę “a” na przedostatnim miejscu.

Odpowiednikiem funkcji Licz.Jeżeli w VBA jest funkcja arkuszowa CountIf.


 

 

Kurs Excel 2010 esencja

 

Łączenie tekstów

W jaki sposób łączyć wartości zapisane w komórkach Excela? Służy do tego przede wszystkim funkcja tekstowa Excela Złącz.Teksty.
Funkcja ta może mieć do 255 argumentów, będących albo wpisanymi wartościami albo odwołaniami do komórek .  W wyniku jej działania otrzymujemy wartość tekstową.

W przykładzie z grafiki powyżej argumenty 1 i 3 to odwołania do adresów komórek, natomiast argument drugi to tekst, a dokładnie rzecz biorąc ” ” czyli cudzysłów spacja cudzysłów.

Identyczny efekt jak w przypadku zastosowania funkcji Złącz.Teksty możemy osiągnąć również poprzez zastosowania znaku konkatenacji czyli & . W tym przypadku wpisujemy formułe bezpośrednio w pasku formuły.

Efekt końcowy jest identyczny.

W obydwu przypadkach warto pamiętać o tym, że łączone są wartości tekstowe . Jeżeli odwołujemy się do komórki z liczbą, to pobierana jest ona jako tekst. Czasami mogą się przez to pojawiać niespodzianki, np. takie:

Wprawdzie w komórce w kolumnie H jest data, ale w wyniku złączenia widzimy dziwną liczbę 43844. I nie ma w tym nic dziwnego – data w Excelu to przecież liczba.
Data w Excelu to liczba
A to, co widzimy na ekranie to tylko kwestia formatowania.

Kurs Excel 2013 od podstaw

Adres komórki

Każda komórka w arkuszu ma swój adres składający się z kolumny i numeru wiersza, na przecięciu których się znajduje. Kolumny są oznaczone literami (A, B, C, D …), natomiast wiersze – liczbami.

Widoczna na screenie aktywna komórka znajduje się na przecięciu kolumny oznaczonej jako A i pierwszego wiersza i ma adres A1. Adres ten jest widoczny w polu nazwy, z lewej strony nad oznaczeniami kolumn. Jest to adres względny komórki. W Excelu odróżniamy także adres bezwzględny – $A$1, a także adresy mieszane: $A1 (bezwzględne odwołanie do kolumny i względne do wiersza) i A$1 (względne odwołanie do kolumny i bezwzględne do wiersza).

Z adresów korzystamy wstawiając w komórkach funkcje i odwołania. Excel domyślnie wstawia tu adresy względne, chcąc zmienić taki adres na bezwzględny lub mieszany – ustawiamy się na nim w pasku formuły i naciskamy F4. Kolejne naciśnięcia F4 powodują zmiany adresów z względnego na bezwzględny i mieszane.

A po co to wszystko? Adresy są wykorzystywane przede wszystkim w formułach. Po skopiowaniu (np. przeciągnięciu w dół) formuł – w zależności od typu adresu przy adresach względnych następuje zmiana numeru wiersza/kolumny, natomiast przy wykorzystaniu adresu bezwzględnego – odwołanie jest zawsze do tej samej komórki.
W przykładzie na screenie widać prosty przykład:

Kolumna kwoty jest iloczynem Ceny, ilości i kursu euro.
W kolumnie D jest odwołanie względne do wartości w kolumnach B i C tego samego wiersza oraz bezwzględne do komórki B2. Po przeciągnięciu w kolejne wiersze tabeli – nie trzeba zmieniać formuły, wszystkie odwołania będą działać prawidłowo.
Ten przykład jest banalny i łatwi do zauważenia. Jeżeli jednak odwołujemy się do zakresów danych (np. w funkcjach wyszukiwania) – to adresy względne zakresu jako parametr funkcji, po skopiowaniu mogą generować błędne wyniki


 

Kurs Excel dla sprzedawców

Naprawianie Excela

Jak na porządną aplikację Microsoftu przystało również i Excel od czasu do czasu zaczyna się dziwnie zachowywać. To, co wcześniej działało bez problemu, teraz zaczyna chwilami fiksować, zmieniają się ustawienia czy też przestają działać niektóre formanty. Czy to oznaka, że trzeba przeinstalować Office, tracąc przy okazji wszystkie swoje ulubione ustawienia? Niekoniecznie, można spróbować innej opcji. Zalecana przez Microsoft, sprawdzana w praktyce i bardzo często skuteczna – naprawa aplikacji.

W Panelu Sterowania wybieramy Programy i funkcje, a następnie na liście zainstalowanych programów odszukujemy Microsoft Office.

Klikamy prawym przyciskiem myszy i z menu podręcznego wybieramy opcję Napraw. Jeżeli nie ma tej opcji (tak jak u mnie), to wybieramy opcję Zmień i zaznaczamy Napraw w oknie kreatora:

Taka naprawa trwa od kilku do kilkunastu minut i wymaga ponownego uruchomienia komputera. Sprawdziłam w praktyce – to działa. I to nie tylko na Excela, ale na wszystkie programy wchodzące w skład pakietu Office.


 

 

Nagrywanie makr

W jaki sposób stworzyć makro? Najszybciej i najprościej – nagrać je. I nie jest to wcale przenośnia – makro można nagrać tak, jak nagrywamy np.filmik. Oczywiście później kod takiego nagranego makra można edytować i modyfikować, ale podstawy już są.

Tu filmik z mojego kanału YT [VBA dla początkujących] ilustrujący mechanizm nagrywania i podglądania kodu makra:


 

VBA – pierwszy start

Wielu, także zaawansowanych użytkowników Excela, nie znając VBA, nawet nie próbuje automatyzować pracy poprzez choćby nagrywania czy edycję makr. A tymczasem – wcale nie jest to żadna kosmiczna wiedza, łatwo ją przyswoić.
VBA to skrót od Visual Basic Application. Jest to nieco zmodyfikowana i okrojona wersja Visual Basic czyli jednego z przyjaźniejszych języków programowania. W dodatku w pakiecie Office (a więc nie tylko w Excelu, ale i w pozostałych aplikacjach takich jak Word, Access czy Outlook) jest bardzo dobra pomoc systemowa ułatwiająca poznanie wszystkich tajników VBA.
Naprawdę warto poznać.

A na początek -filmik z mojego kanału na YouTube
[VBA dla początkujących]:


Kurs Excel - makra i VBA dla początkujących

Grupowanie danych w tabeli przestawnej

W tabeli przestawnej bardzo często zdarza się konieczność grupowania danych. Robi się to w bardzo prosty sposób, a efekty mogą być naprawdę imponujące.

Załóżmy, że mamy taką prostą tabelkę z danymi:

Tworzymy na jej podstawie tabelę przestawną, sprawdzając ile osób jest w danej kategorii wiekowej.

Efekt osiągnięty, wygląda to jednak mało przyjaźnie i to mimo, że w tabeli jest mało rekordów. Spróbujmy pogrupować te dane, klikając prawym przyciskiem myszy na kolumnie z wiekiem i wybierając z menu podręcznego Grupuj…

W kolejnym kroku ustawiamy parametry grupowania, np. tak:

I w efekcie osiągnięty takim widok skumulowanych danych:

Ciekawy efekt można też otrzymać grupując daty zapisane w ostatniej kolumnie tabeli. W tym przypadku formularz grupowania wygląda tak:

Można zaznaczyć kilka opcji. Po zaznaczeniu lat i kwartałów tabela wygląda tak:

 


Kurs Excel 2010 esencja

Tworzenie tabeli przestawnej

Tabela przestawna to świetne narzędzie Excela pozwalające na szybką i sprawną agregację i analizę danych. Ma to znaczenie szczególnie wtedy, gdy danych jest dużo.

Do pokazania kolejnych kroków tworzenia tabeli przestawnej użyłam pobranego ze strony PKW pliku kandydatów do sejmu w wyborach 2019. Na wszelki wypadek (RODO) usunęłam nazwiska i imiona, zastępując je inicjałami.
A tu filmik


Kurs Excel - tabele przestawne