Kalkulator wyborczy

Kalkulator wyborczy czyli plik Excela przeliczający głosy na mandaty. Uwzględnia przekroczenie progu wyborczego (5% dla partii i 8% dla koalicji). Oczywiście jest oparty o metodę D’Hondta. W roku podwójnych wyborów może się przydać.

Plik Excela do pobrania jest tu:

Kalkulator wyniku wyborów

Plik Excela jest bez makr. A jak działa?

Do wypełnienia są żółte pola. W komórce D6 wpisujemy liczbę mandatów do podziału, w komórkach C4:M4 – oznaczenie T/N dla koalicji, a w komórkach C5:M5 – liczbę głosów uzyskanych przez poszczególne partie. I już całą reszta jest obliczana automatycznie.

Komórka B10 to suma wszystkich głosów czyli suma zakresu C5:M5.
W wierszu 6 mamy formułę np. w C6: =C5/$B$10 – w pozostałych kolumnach wiersza 6 – analogicznie. W ten sposób obliczamy procent uzyskanych głosów dla poszczególnych partii.
W komórce C7 (i analogicznie w kolumnach od D do M) jest formuła:
=JEŻELI(C4=”T”;JEŻELI(C6>=8%;”T”;”N”);JEŻELI(C6>=5%;”T”;”N”))
– następuje tu sprawdzenie, w zależności od tego czy jest to koalicja czy nie, czy został przekroczony próg wyborczy.

Metoda H’ondta polega na tym, że w pierwszym kroku wstawiamy do tabeli wszystkie wyniki, w kolejnym wierszu – dzielimy te wartości przez 2, w następnym – przez 3 itd.
Wyniki tych obliczeń są umieszczone od wiersza 14 w dół.

Formuły zawarte w wierszu 14 – to:
np. komórka C14: =JEŻELI(LUB(C5=””;C7=”N”);0;C5) – czyli jeżeli w tabeli z danymi w kolumnie nie ma wartości lub wynik działania formuły w wierszu 7 jest “N”  – jest ona pobierana do wiersza 14, jeżeli nie – ZERO.

Od wiersza 15 – formuła wygląda tak:
np. w komórce C15: =JEŻELI(LUB(C14=””;C14jeżeli w komórce  powyżej jest wartość co najmniej 1 – jest ona dzielona przez wartość w komórce B15 czyli 2. Analogicznie – w kolejnych wierszach.

Formuła B13 jest natomiast formuła:

=MAX.K(C14:M313;D1)

Wyznacza ona k-tą wartość maksymalną z zakresu obliczeń. Wartość k jest wyznaczona przez liczbę mandatów do podziału – zapisana jest w komórce D1. Wartości większe i równe tej wartości minimalnej są oznaczone w obliczeniach na jasnoniebiesko. Tu wykorzystałam formatowanie warunkowe:

W wierszu 8 jest wyznaczona liczba mandatów dla danej partii. Zastosowałam tu formułę:
=JEŻELI(C7=”T”;LICZ.JEŻELI(C14:C313;”>=” &$B13);0)

Następuje tu sprawdzenie – ile w zakresie obliczeń dla danej kolumny występuje liczb niemniejszych od B7.

I już, wszystko jasne. – można wspomóc PKW kalkulatorem wyborczym.

Usuwanie zabezpieczeń Outlooka

Korzystając z automatycznego mailingu czyli wysyłania maili w Outlooku poprzez aplikację w Excelu czy Accessie, możemy natknąć się na blokadę Outlooka. Na ekranie pojawia się komunikat, że pewien program próbuje wysłać wiadomość. Po dłuższej chwili odblokowują się przyciski i można wyrazić zgodę, jednak przy kolejnym mailu sytuacja się powtarza. W efekcie okazuje się, że cały automatyzm przestaje być skuteczny i nie ma sensu.

Można sobie z tym poradzić za pomocą programu Outlook WarningDoctor firmy CodeTwo. Jest darmowy, bezpieczny i często polecany. Do pobrania na stronie:

Outlook WarningDoctor

Po pobraniu i zainstalowaniu – nic już nie przeszkadza w automatycznym wysyłaniu maili.
A przy okazji zapraszam tu:
Aplikacja do mailingu

 

 

 

Kurs Outlook - efektywna praca

Pora na remont

Do tej pory przez 9 lat prowadziłam blog
Excel, Access, VBA
na platformie blogowej Blox. Niestety, pod koniec kwietnia ’19 Agora zamyka Bloxa i trzeba znaleźć nowe miejsce w sieci. Owszem, przeniosłam stary blog na WordPress.com, ale nie wszystko wyszło tak, jak bym chciała. Przede wszystkim z większości notek zniknęły zdjęcia (a dokładnie – screeny ilustrujące opisywaną treść), wstawione linki odwołujące się do innych notek też nie działają. Blog ten jest tu:
Excel, Access, VBA – archiwum na WordPress
Wszystko to można poprawić, ale każdą z prawie 600 notek trzeba przejrzeć, poustawiać wszystko na nowo i trochę traci to sens. Archiwum zostaje, ale postanowiłam zacząć od nowa. Wykorzystam swoje doświadczenia, przy okazji reorganizując swoje blogowisko. W przypadku tego blogu postanowiłam rozdzielić Excel od Accessa. Ten blog pozostanie blogiem “excelowym”, o Accessie założę nowy blog.

Sporo pracy przede mną.