Licz.Warunki

Licz.Warunki to jedna z funkcji statystycznych Excela. W wyniku jej działania zliczana ilość komórek spełniających określone kryteria wyszukiwania.
Argumenty funkcji to:

    • Kryteria_zakres1 – zakres komórek, w którym chcemy wyliczyć ilość spełniających dany warunek
    • Kryteria1 – warunek wymagany do spełnienia

Zasady stosowania są identyczne jak opisane w notce dotyczącej funkcji Licz.Jeżeli, nie będę więc ich tu powielać.
Polecam też notkę o tworzeniu kryteriów wyszukiwania.
Takich par kryteriów może być 127. To, co najistotniejsze – wszystkie te warunki muszą być spełnione jednocześnie dla każdego rekordu. Działa tu funkcja ORAZ czyli iloczyn logiczny..

W praktyce wygląda to tak:
Załóżmy, że w tabeli jak na ilustracji chcemy policzyć ile osób o nazwisku Nowak ma przypisaną kwotę co najmniej 100zł:

Formuła dla takiego przypadku:
=LICZ.WARUNKI(A:A;”Nowak”;D:D;”>=100″)
A ile kobiet o nazwisku Nowak i mężczyzn o nazwisku kończącym się na k (ale nie Nowak) wpłaciło powyżej 20zł? W takim przypadku musimy zastosować sumę czyli:
=LICZ.WARUNKI(A:A;”Nowak”;B:B;”K”;D:D;”>20″)+LICZ.WARUNKI(A:A;”k”;A:A;”<>Nowak”;B:B;”M”;D:D;”>20″)

Odpowiednikiem funkcji Licz.Warunki w VBA jest funkcja arkuszowa CountIfs.

 


 

Kurs Excel - zaawansowane funkcje i formuły

 

Licz.Jeżeli

Licz.Jeżeli to jedna z funkcji statystycznych Excela. W wyniku jej działania otrzymujemy ilość komórek spełniających określone kryterium wyszukiwania.
Argumenty funkcji to:

      • Zakres – zakres komórek, w którym chcemy wyliczyć iloś ć komórek spełniających dany warunek
      • Kryteria – warunek do spełnienia

Obydwa argumenty są wymagane.

Polecam też notkę o tworzeniu kryteriów wyszukiwania.

W praktyce  wygląda to tak:

Mamy prostą tabelkę z danymi. Chcąc policzyć ile jest kobiet (czyli oznaczenie “K” w kolumnie B) przy użyciu funkcji Licz.Jeżeli zapisujemy:
=LICZ.JEŻELI(B2:B14;”K”)
Argumentu Kryteria nie musimy wpisywać w cudzysłowie, Excel sam przekształci wpisaną tam wartość w tekst. Wielkość liter nie ma tu znaczenia.
Gdybyśmy chcieli policzyć ilość mężczyzn – jako kryterium wystarczy wstawić literkę M.
Chcąc natomiast policzyć ilość osób, które wpłaciły np.10zł – możemy zastosować formułę:
=LICZ.JEŻELI(D2:D14;10)

Kryterium nie musi być jednak wpisywane na sztywno do funkcji. Można tu odwoływać się do wartości w innej komórce. W załączonym przykładzie niech będzie to np.komórka F1. Formuła odwołująca się do niej to:
=LICZ.JEŻELI(B2:B14;F1)
Jeżeli w komórce F1 wpiszemy np.K – to funkcja zwróci nam ilość kobiet. Wystarczy zmienić na M i policzymy mężczyzn.

Kryterium wyszukiwania może być także bardziej złożone. Jeżeli chcielibyśmy np. sprawdzić, do ilu osób w tabelce przypisana jest np. kwota powyżej 100zł możemy zastosować formułę:
=LICZ.JEŻELI(D2:D14;”>100″)
lub odwołując się do wartości np.w komórce F1:
=LICZ.JEŻELI(D2:D14;”>” & F1)
Warto zauważyć, że adres komórki (czyli F1) musi być poza znakiem cudzysłowu, korzystamy tu z łączenia tekstów za pomocą znaku konkatenacji &.

Można też tworzyć bardziej złożone kryteria. Załóżmy, że w kolumnie A chcemy wyszukać liczbę imion rozpoczynających się na literę A. Formuła w tym przypadku będzie wyglądać tak:
=LICZ.JEŻELI(A2:A14;”A*”)
Znak * oznacza dowolny ciąg tekstowy, o dowolnej długości, również zerowy. W przypadku odwołania do komórki F1 wygląda to tak:
=LICZ.JEŻELI(A2:A14;F1 & “*”)

Symbol ? oznacza dokładnie jeden znak. Czyli funkcja
=LICZ.JEŻELI(A2:A14;”*a?”)
wskaże ilość komórek w kolumnie A, zawierających literę “a” na przedostatnim miejscu.

Odpowiednikiem funkcji Licz.Jeżeli w VBA jest funkcja arkuszowa CountIf.


 

 

Kurs Excel 2010 esencja

 

Łączenie tekstów

W jaki sposób łączyć wartości zapisane w komórkach Excela? Służy do tego przede wszystkim funkcja tekstowa Excela Złącz.Teksty.
Funkcja ta może mieć do 255 argumentów, będących albo wpisanymi wartościami albo odwołaniami do komórek .  W wyniku jej działania otrzymujemy wartość tekstową.

W przykładzie z grafiki powyżej argumenty 1 i 3 to odwołania do adresów komórek, natomiast argument drugi to tekst, a dokładnie rzecz biorąc ” ” czyli cudzysłów spacja cudzysłów.

Identyczny efekt jak w przypadku zastosowania funkcji Złącz.Teksty możemy osiągnąć również poprzez zastosowania znaku konkatenacji czyli & . W tym przypadku wpisujemy formułe bezpośrednio w pasku formuły.

Efekt końcowy jest identyczny.

W obydwu przypadkach warto pamiętać o tym, że łączone są wartości tekstowe . Jeżeli odwołujemy się do komórki z liczbą, to pobierana jest ona jako tekst. Czasami mogą się przez to pojawiać niespodzianki, np. takie:

Wprawdzie w komórce w kolumnie H jest data, ale w wyniku złączenia widzimy dziwną liczbę 43844. I nie ma w tym nic dziwnego – data w Excelu to przecież liczba.
Data w Excelu to liczba
A to, co widzimy na ekranie to tylko kwestia formatowania.

Kurs Excel 2013 od podstaw